User Spam Remover <= 1.0 - Unauthenticated Sensitive Information Exposure

Information Exposure
CVE CVE-2024-31298
CVSS 5.3 (Medium)
Publicly Published April 5, 2024
Last Updated April 11, 2024
Researcher Joshua Chan


The User Spam Remover plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.0 via a log file. This makes it possible for unauthenticated attackers to extract sensitive data from log files.



Vulnerability Details for User Spam Remover

Software Type Plugin
Software Slug user-spam-remover (view on
Patched? Yes
Remediation Update to version 1.1, or a newer patched version
Affected Version
  • <= 1.0
Patched Version
  • 1.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.