User Verification <= 1.0.93 - Privilege Escalation

Improper Authentication
CVE CVE-2022-4693
CVSS 9.8 (Critical)
Publicly Published December 28, 2022
Last Updated January 23, 2023
Researcher Lana Codes


The User Verification plugin for WordPress is vulnerable to authentication bypass. This is due to the fact that when generating OTP codes for users to use in order to login, the plugin returns these codes in an AJAX response. This makes it possible for unauthenticated attackers to obtain login codes for administrators.



1 affected software package

Software Type Plugin
Software Slug user-verification (view on
Patched? Yes
Remediation Update to version 1.0.94, or a newer patched version
Affected Version
  • <= 1.0.93
Patched Version
  • 1.0.94

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.