Userback <= 1.0.13 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-46089
CVSS 4.3 (Medium)
Publicly Published October 17, 2023
Last Updated October 30, 2023
Researcher LEE SE HYOUNG


The Userback plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.13. This is due to missing nonce validation on the userback_save() function. This makes it possible for unauthenticated attackers to update userback user settings via a forged request, granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug userback (view on
Patched? Yes
Remediation Update to version 1.0.14, or a newer patched version
Affected Version
  • <= 1.0.13
Patched Version
  • 1.0.14

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.