UserPro <= 5.1.1 - Authentication Bypass to Administrator

9.8
Authentication Bypass Using an Alternate Path or Channel
CVE CVE-2023-2437
CVSS 9.8 (Critical)
Publicly Published November 21, 2023
Last Updated November 22, 2023
Researcher István Márton - Wordfence

Description

The UserPro plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 5.1.1. This is due to insufficient verification on the user being supplied during a Facebook login through the plugin. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the email. An attacker can leverage CVE-2023-2448 and CVE-2023-2446 to get the user's email address to successfully exploit this vulnerability.

References

Share

1 affected software package

Software Type Plugin
Software Slug userpro
Patched? Yes
Remediation Update to version 5.1.2, or a newer patched version
Affected Version
  • <= 5.1.1
Patched Version
  • 5.1.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation