UserPro <= 5.1.1 - Sensitive Information Disclosure via Shortcode

Information Exposure
CVE CVE-2023-2446
CVSS 6.5 (Medium)
Publicly Published November 21, 2023
Last Updated January 22, 2024
Researcher István Márton - Wordfence


The UserPro plugin for WordPress is vulnerable to sensitive information disclosure via the 'userpro' shortcode in versions up to, and including 5.1.1. This is due to insufficient restriction on sensitive user meta values that can be called via that shortcode. This makes it possible for authenticated attackers, with subscriber-level permissions, and above to retrieve sensitive user meta that can be used to gain access to a high privileged user account.

Wordfence blocked 99 attacks targeting this vulnerability in the past 24 hours.



Vulnerability Details for UserPro - Community and User Profile WordPress Plugin

Software Type Plugin
Software Slug userpro
Patched? Yes
Remediation Update to version 5.1.2, or a newer patched version
Affected Version
  • <= 5.1.1
Patched Version
  • 5.1.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.