UserPro <= 5.1.4 - Authenticated (Subscriber+) Privilege Escalation

Incorrect Privilege Assignment
CVE CVE-2023-6009
CVSS 8.8 (High)
Publicly Published November 21, 2023
Last Updated January 22, 2024
Researcher István Márton - Wordfence


The UserPro plugin for WordPress is vulnerable to privilege escalation in versions up to, and including, 5.1.4 due to insufficient restriction on the 'userpro_update_user_profile' function. This makes it possible for authenticated attackers, with minimal permissions such as a subscriber, to modify their user role by supplying the 'wp_capabilities' parameter during a profile update.



1 affected software package

Software Type Plugin
Software Slug userpro
Patched? Yes
Remediation Update to version 5.1.5, or a newer patched version
Affected Version
  • <= 5.1.4
Patched Version
  • 5.1.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.