VaultPress <=1.9 - Remote Code Execution

Improper Control of Generation of Code ('Code Injection')
CVSS 9.8 (Critical)
Publicly Published September 16, 2017
Last Updated January 22, 2024
Researcher Slavco Mihajloski


The VaultPress plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 1.9 via the openssl_verify function. This allows unauthenticated attackers to execute code on the server.



Vulnerability Details for Jetpack VaultPress

Software Type Plugin
Software Slug vaultpress (view on
Patched? Yes
Remediation Update to version 1.9.1, or a newer patched version
Affected Version
  • <= 1.9
Patched Version
  • 1.9.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.