Video Conferencing with Zoom <= 4.2.1 - Sensitive Information Exposure

Use of Hard-coded Cryptographic Key
CVE CVE-2023-3947
CVSS 3.7 (Low)
Publicly Published July 25, 2023
Last Updated July 26, 2023
Researcher István Márton - Wordfence


The Video Conferencing with Zoom plugin for WordPress is vulnerable to Sensitive Information Exposure due to hardcoded encryption key on the 'vczapi_encrypt_decrypt' function in versions up to, and including, 4.2.1. This makes it possible for unauthenticated attackers to decrypt and view the meeting id and password.



Vulnerability Details for Video Conferencing with Zoom

Software Type Plugin
Software Slug video-conferencing-with-zoom-api (view on
Patched? Yes
Remediation Update to version 4.2.2, or a newer patched version
Affected Version
  • <= 4.2.1
Patched Version
  • 4.2.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.