Post Video Players <= 1.159 - Cross-Site Request Forgery via cincopa_mp_mt_options_page

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-23515
CVSS 4.3 (Medium)
Publicly Published January 30, 2024
Last Updated March 25, 2024
Researcher Skalucy


The Cincopa video and media plug-in plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.159. This is due to missing or incorrect nonce validation on the 'cincopa_mp_mt_options_page' function. This makes it possible for unauthenticated attackers to modify the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Cincopa video and media plug-in

Software Type Plugin
Software Slug video-playlist-and-gallery-plugin (view on
Patched? Yes
Remediation Update to version 1.160, or a newer patched version
Affected Version
  • <= 1.159
Patched Version
  • 1.160

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.