Views for WPForms <= 3.2.2 - Cross-Site Request Forgery via save_view

Improper Access Control
CVE CVE-2024-0373
CVSS 4.3 (Medium)
Publicly Published January 24, 2024
Last Updated February 5, 2024
Researcher Francesco Carlucci


The Views for WPForms – Display & Edit WPForms Entries on your site frontend plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.2.2. This is due to missing or incorrect nonce validation on the 'save_view' function. This makes it possible for unauthenticated attackers to modify arbitrary post titles via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Views for WPForms – Display & Edit WPForms Entries on your site frontend

Software Type Plugin
Software Slug views-for-wpforms-lite (view on
Patched? Yes
Remediation Update to version 3.2.3, or a newer patched version
Affected Version
  • <= 3.2.2
Patched Version
  • 3.2.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.