Visual Portfolio, Photo Gallery & Post Grid <= 2.18.0 - Contributor+ CSS Injection

Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
CVE CVE-2022-2597
CVSS 4.3 (Medium)
Publicly Published August 15, 2022
Last Updated December 5, 2022
Researcher Krzysztof Zając - CERT PL


The Visual Portfolio, Photo Gallery & Post Grid plugin for WordPress is vulnerable to CSS injection via the REST API in versions up to, and including, 2.18.0. This allows authenticated users with contributor or greater privileges to inject arbitrary CSS into saved layouts.



Vulnerability Details for Visual Portfolio, Photo Gallery & Post Grid

Software Type Plugin
Software Slug visual-portfolio (view on
Patched? Yes
Remediation Update to version 2.19.0, or a newer patched version
Affected Version
  • <= 2.18.0
Patched Version
  • 2.19.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.