Visual Composer Website Builder <= 45.0 - Authenticated Stored Cross-Site Scripting via 'Text Block'

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-2430
CVSS 6.4 (Medium)
Publicly Published August 29, 2022
Last Updated January 22, 2024
Researcher Zhouyuan Yang - Fortinet's FortiGuard Labs


The Visual Composer Website Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Text Block' feature in versions up to, and including, 45.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers with access to the visual composer editor to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for Visual Composer Website Builder, Landing Page Builder, Custom Theme Builder, Maintenance Mode & Coming Soon Pages

Software Type Plugin
Software Slug visualcomposer (view on
Patched? Yes
Remediation Update to version 45.0.1, or a newer patched version
Affected Version
  • <= 45.0
Patched Version
  • 45.0.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.