WooCommerce Dynamic Pricing and Discounts <= 2.4.1 - Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-4372
CVSS 6.5 (Medium)
Publicly Published August 31, 2021
Last Updated June 7, 2023
Researcher Jerome Bruandet - NinTechNet


The WooCommerce Dynamic Pricing and Discounts plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.4.1. This is due to missing sanitization on the settings imported via the import() function. This makes it possible for unauthenticated attackers to import a settings file containing malicious JavaScript that would execute when an administrator accesses the settings area of the site.



1 affected software package

Software Type Plugin
Software Slug wc-dynamic-pricing-and-discounts
Patched? Yes
Remediation Update to version 2.4.2, or a newer patched version
Affected Version
  • < 2.4.2
Patched Version
  • 2.4.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.