WCFM Frontend Manager <= 6.6.0 - Missing Authorization

Missing Authorization
CVE CVE-2022-4937
CVSS 6.3 (Medium)
Publicly Published April 5, 2023
Last Updated April 5, 2023
Researcher Chloe Chamberland - Wordfence


The WCFM Frontend Manager plugin for WordPress is vulnerable to unauthorized modification and access of data in versions up to, and including, 6.6.0 due to missing capability checks on various AJAX actions. This makes it possible for authenticated attackers, with minimal permissions such as subscribers, to perform a wide variety of actions such as modifying knowledge bases, modifying notices, modifying payments, managing vendors, capabilities, and so much more. There were hundreds of AJAX endpoints affected.



1 affected software package

Software Type Plugin
Software Slug wc-frontend-manager (view on wordpress.org)
Patched? Yes
Remediation Update to version 6.6.1, or a newer patched version
Affected Version
  • 6.6.0 - 6.6.0
Patched Version
  • 6.6.1

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.