WCFM Marketplace <= 3.4.12 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2022-4936
CVSS 6.3 (Medium)
Publicly Published April 5, 2023
Last Updated April 5, 2023
Researcher Chloe Chamberland - Wordfence


The WCFM Marketplace plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.4.11 due to missing nonce checks on various AJAX actions. This makes it possible for unauthenticated attackers to perform a wide variety of actions such as modifying shipping method details, modifying products, deleting arbitrary posts, and more, via a forged request granted they can trick a site's administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug wc-multivendor-marketplace (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.5.0, or a newer patched version
Affected Version
  • <= 3.4.12
Patched Version
  • 3.5.0

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.