WCFM Membership <= 2.10.0 - Unauthenticated Privilege Escalation

Missing Authorization
CVE CVE-2022-4939
CVSS 9.8 (Critical)
Publicly Published April 5, 2023
Last Updated January 22, 2024
Researcher Chloe Chamberland - Wordfence


THe WCFM Membership plugin for WordPress is vulnerable to privilege escalation in versions up to, and including 2.10.0, due to a missing capability check on the wp_ajax_nopriv_wcfm_ajax_controller AJAX action that controls membership settings. This makes it possible for unauthenticated attackers to modify the membership registration form in a way that allows them to set the role for registration to that of any user including administrators. Once configured, the attacker can then register as an administrator.



Vulnerability Details for WCFM Membership – WooCommerce Memberships for Multivendor Marketplace

Software Type Plugin
Software Slug wc-multivendor-membership (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.10.1, or a newer patched version
Affected Version
  • <= 2.10.0
Patched Version
  • 2.10.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.