BuddyPress WooCommerce My Account Integration. Create WooCommerce Member Pages <= 3.4.20 - Authenticated (Subscriber+) PHP Object Injection in get_simple_request

Deserialization of Untrusted Data
CVE CVE-2024-2025
CVSS 8.8 (High)
Publicly Published March 22, 2024
Last Updated April 24, 2024
Researcher Francesco Carlucci


The "BuddyPress WooCommerce My Account Integration. Create WooCommerce Member Pages" plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.4.20 via deserialization of untrusted input in the get_simple_request function. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject a PHP Object. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code. CVE-2024-32603 is likely a duplicate of this issue.



Vulnerability Details for BuddyPress WooCommerce My Account Integration. Create WooCommerce Member Pages

Software Type Plugin
Software Slug wc4bp (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.4.21, or a newer patched version
Affected Version
  • <= 3.4.20
Patched Version
  • 3.4.21

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.