Web Stories <= 1.24.0 - Server Side Request Forgery

9.6
Server-Side Request Forgery (SSRF)
CVE CVE-2022-3708
CVSS 9.6 (Critical)
Publicly Published October 26, 2022
Last Updated December 20, 2022
Researcher Aymen Borgi

Description

The Web Stories plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including 1.24.0 due to insufficient validation of URLs supplied via the 'url' parameter found via the /v1/hotlink/proxy REST API Endpoint. This makes it possible for authenticated users to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

References

Share

1 affected software package

Software Type Plugin
Software Slug web-stories (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.25.0, or a newer patched version
Affected Version
  • <= 1.24.0
Patched Version
  • 1.25.0

All the threat data shared in this database is powered by Wordfence Intelligence.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence Community Edition WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation