Webpushr <= 4.34.0 - Missing Authorization to Unauthenticated Stored Cross-Site Scripting

Missing Authorization
CVE CVE-2023-5620
CVSS 7.2 (High)
Publicly Published November 6, 2023
Last Updated November 7, 2023
Researcher Krzysztof Zając - CERT PL


The Web Push Notifications – Webpushr plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the wpp_save_settings function in all versions up to, and including, 4.34.0. This makes it possible for unauthenticated attackers to modify plugin options and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for Web Push Notifications – Webpushr

Software Type Plugin
Software Slug webpushr-web-push-notifications (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.35.0, or a newer patched version
Affected Version
  • <= 4.34.0
Patched Version
  • 4.35.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.