weDocs <= 2.1.4 - Missing Authorization

5.3
Missing Authorization
CVE CVE-2024-34442
CVSS 5.3 (Medium)
Publicly Published May 7, 2024
Last Updated May 16, 2024
Researcher Peng Zhou

Description

The weDocs plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the update_helpfullness REST API endpoint in versions up to, and including, 2.1.4. This makes it possible for unauthenticated attackers to update settings.

References

Share

Vulnerability Details for The Best WordPress Knowledgebase and Documentation Plugin – weDocs

Software Type Plugin
Software Slug wedocs (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.1.5, or a newer patched version
Affected Version
  • <= 2.1.4
Patched Version
  • 2.1.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation