Wholesale Market <= 2.2.0 - Information Disclosure via Unauthenticated Arbitrary File Download

7.5
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2022-4298
CVSS 7.5 (High)
Publicly Published December 12, 2022
Last Updated December 15, 2022
Researcher cydave

Description

The Wholesale Market plugin for WordPress is vulnerable to arbitrary file download due to missing file name validation via the ced_cwsm_log_download parameter in versions up to, and including, 2.2.0. This makes it possible for unauthenticated attackers to download arbitrary files on the affected site's server leading to Information Disclosure.

References

Share

1 affected software package

Software Type Plugin
Software Slug wholesale-market (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2.1, or a newer patched version
Affected Version
  • <= 2.2.0
Patched Version
  • 2.2.1

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation