WidgetKit <= 2.5.0 - Missing Authorization to Notice Dismissal

Missing Authorization
CVE CVE-2024-33908
CVSS 5.3 (Medium)
Publicly Published April 29, 2024
Last Updated May 7, 2024
Researcher Dhabaleshwar Das


The WidgetKit plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the wk_td_ads_dismiss_notice() function in versions up to, and including, 2.4.8. This makes it possible for unauthenticated attackers to dismiss notices.



Vulnerability Details for All-in-One Addons for Elementor – WidgetKit

Software Type Plugin
Software Slug widgetkit-for-elementor (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • <= 2.4.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.