Wise Chat <= 2.8.3 - CSV Injection

Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
CVSS 5.5 (Medium)
Publicly Published July 9, 2020
Last Updated January 22, 2024
Researcher Vishnupriya Ilango - Fortinet's FortiGuard Labs


The Wise Chat plugin for WordPress is vulnerable to CSV Injection in versions up to, and including, 2.8.3. This allows unauthenticated attackers to embed untrusted input into exported CSV files, which can result in code execution when these files are downloaded and opened on a local system with a vulnerable configuration.



Vulnerability Details for Wise Chat

Software Type Plugin
Software Slug wise-chat (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.8.4, or a newer patched version
Affected Version
  • <= 2.8.3
Patched Version
  • 2.8.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.