Woocommerce Blocker Lite <= 2.1.5 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-39159
CVSS 4.3 (Medium)
Publicly Published July 26, 2023
Last Updated August 21, 2023
Researcher Mika


The Woocommerce Blocker Lite plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.1.5. This is due to missing nonce validation on several of the plugin's functions like wcblu_custom_add_update_options(), wcblu_update_general_settings(), and wcblu_update_rules_settings(). This makes it possible for unauthenticated attackers to invoke this function and update the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug woo-blocker-lite-prevent-fake-orders-and-blacklist-fraud-customers (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.1.6, or a newer patched version
Affected Version
  • <= 2.1.5
Patched Version
  • 2.1.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.