Coupon Affiliates <= 5.4.3 - Unauthenticated Stored Cross-Site Scripting

7.2
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-28992
CVSS 7.2 (High)
Publicly Published March 31, 2023
Last Updated April 3, 2023
Researcher thiennv

Description

The Coupon Affiliates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'wcu_coupons' parameter in versions up to, and including, 5.4.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Share

1 affected software package

Software Type Plugin
Software Slug woo-coupon-usage (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.4.4, or a newer patched version
Affected Version
  • <= 5.4.3
Patched Version
  • 5.4.4

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation