Discount Rules for WooCommerce <= 2.0.2 - Missing Authorization

6.3
Missing Authorization
CVSS 6.3 (Medium)
Publicly Published August 20, 2020
Last Updated January 22, 2024
Researcher Patchstack - Patchstack

Description

The Discount Rules for WooCommerce plugin for WordPress is vulnerable to missing authorization via several AJAX actions in versions up to, and including, 2.0.2 due to missing capability checks on various functions. This makes it possible for subscriber-level attackers to execute various actions and perform a wide variety of actions such as modifying rules and saving configurations.

Wordfence blocked 110 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for Discount Rules for WooCommerce – Create Smart WooCommerce Coupons & Discounts, Bulk Discount, BOGO Coupons

Software Type Plugin
Software Slug woo-discount-rules (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.1.0, or a newer patched version
Affected Version
  • <= 2.0.2
Patched Version
  • 2.1.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation