Orders Tracking for WooCommerce <= 1.2.10 - Unauthenticated Arbitrary Shortcode Execution

Improper Control of Generation of Code ('Code Injection')
CVE CVE-2024-4039
CVSS 6.5 (Medium)
Publicly Published May 9, 2024
Last Updated May 10, 2024
Researcher stealthcopter


The The Orders Tracking for WooCommerce plugin for WordPress for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 1.2.10. This is due to the plugin allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. A partial patch was released in 1.2.10, and a complete patch was released in 1.2.11.



Vulnerability Details for Orders Tracking for WooCommerce

Software Type Plugin
Software Slug woo-orders-tracking (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.11, or a newer patched version
Affected Version
  • <= 1.2.10
Patched Version
  • 1.2.11

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.