WooCommerce PDF Invoice Builder <= 1.2.90 - Cross-Site Request Forgery to Custom Field Creation

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-4161
CVSS 4.3 (Medium)
Publicly Published August 16, 2023
Last Updated January 22, 2024
Researcher Marco Wotschka - Wordfence


The WooCommerce PDF Invoice Builder for WordPress is vulnerable to Cross-Site Request Forgery due to a missing nonce check on the SaveCustomField function in versions up to, and including, 1.2.90. This makes it possible for unauthenticated attackers to create invoice fields provided they can trick an admin into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug woo-pdf-invoice-builder (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.91, or a newer patched version
Affected Version
  • <= 1.2.90
Patched Version
  • 1.2.91

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.