WooCommerce PensoPay <= 6.3.1 - Reflected Cross-Site Scripting via 'pensopay_action'

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-41691
CVSS 6.1 (Medium)
Publicly Published September 5, 2023
Last Updated September 7, 2023
Researcher Le Ngoc Anh - sun*inc


The WooCommerce PensoPay plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'pensopay_action' parameter in versions up to, and including, 6.3.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.



Vulnerability Details for WooCommerce PensoPay

Software Type Plugin
Software Slug woo-pensopay (view on wordpress.org)
Patched? Yes
Remediation Update to version 6.3.2, or a newer patched version
Affected Version
  • <= 6.3.1
Patched Version
  • 6.3.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.