Category Discount Woocommerce <= 4.11 - Cross-Site Request Forgery via wpcd_save_discount()

5.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2024-0617
CVSS 5.3 (Medium)
Publicly Published January 24, 2024
Last Updated January 24, 2024
Researcher Krzysztof Zając - CERT PL

Description

The Category Discount Woocommerce plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.12. This is due to missing or incorrect nonce validation on the wpcd_save_discount() function. This makes it possible for unauthenticated attackers to modify product category discounts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

1 affected software package

Software Type Plugin
Software Slug woo-product-category-discount (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.12, or a newer patched version
Affected Version
  • <= 4.11
Patched Version
  • 4.12

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation