WooCommerce Product Enquiry <= 2.6.0 - Unauthenticated Self-Based Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-32796
CVSS 4.7 (Medium)
Publicly Published November 8, 2023
Last Updated May 17, 2024
Researcher Emili Castells


The WooCommerce Product Enquiry plugin for WordPress is vulnerable to Self-Cross-Site Scripting via the enquiry form fields in versions up to, and including, 2.6.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in the page an enquiry form is on, though it would require successful social engineering to get the user to input the malicious payload into form fields.



Vulnerability Details for WooCommerce Product Enquiry

Software Type Plugin
Software Slug woo-product-enquiry (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.7.0, or a newer patched version
Affected Version
  • <= 2.6.0
Patched Version
  • 2.7.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.