Abandoned Cart Lite for WooCommerce <= 5.14.1 - Cross-Site Request Forgery via delete_expired_used_coupon_code

4.3
Cross-Site Request Forgery (CSRF)
CVSS 4.3 (Medium)
Publicly Published May 22, 2023
Last Updated May 23, 2023

Description

The Abandoned Cart Lite for WooCommerce plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 5.14.1. This is due to missing or incorrect nonce validation on the 'delete_expired_used_coupon_code' function. This makes it possible for unauthenticated attackers to delete expired coupon codes granted they can trick a site administrator into performing an action such as clicking on a link. The impact of this vulnerability is unknown.

References

Share

1 affected software package

Software Type Plugin
Software Slug woocommerce-abandoned-cart (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.14.2, or a newer patched version
Affected Version
  • < 5.14.2
Patched Version
  • 5.14.2

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation