Abandoned Cart Lite for WooCommerce <= 5.16.0 - Improper Authorization via wcal_delete_expired_used_coupon_code

Improper Authorization
CVSS 3.1 (Low)
Publicly Published November 21, 2023
Last Updated November 21, 2023


The Abandoned Cart Lite for WooCommerce plugin for WordPress is vulnerable to unauthorized loss of data due to invalid logic in the capability check present in the wcal_delete_expired_used_coupon_code function in all versions up to and including 5.16.0. This makes it possible for authenticated attackers with subscriber privileges or above to delete expired used coupon codes, granted they are able to obtain a nonce via a separate vulnerability.



Vulnerability Details for Abandoned Cart Lite for WooCommerce

Software Type Plugin
Software Slug woocommerce-abandoned-cart (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.16.1, or a newer patched version
Affected Version
  • < 5.16.1
Patched Version
  • 5.16.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.