WooCommerce Bookings <= 1.15.78 - Insecure Direct Object Reference

Authorization Bypass Through User-Controlled Key
CVE CVE-2023-32747
CVSS 4.3 (Medium)
Publicly Published May 15, 2023
Last Updated May 19, 2023
Researcher Rafie Muhammad - Patchstack


The WooCommerce Bookings plugin for WordPress is vulnerable to insecure direct object reference in versions up to, and including, 1.15.78. This is due to insufficient validation on a user controlled key. The impact of this vulnerability is unknown.



1 affected software package

Software Type Plugin
Software Slug woocommerce-bookings
Patched? Yes
Remediation Update to version 1.15.79, or a newer patched version
Affected Version
  • <= 1.15.78
Patched Version
  • 1.15.79

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.