Checkout Field Editor <= 1.7.4 - Cross-Site Request Forgery to Checkout Fields Update

Cross-Site Request Forgery (CSRF)
CVSS 4.3 (Medium)
Publicly Published September 11, 2023
Last Updated September 19, 2023
Researcher foobar7


The Checkout Field Editor plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.7.4. This is due to missing nonce validation when updating checkout fields. This makes it possible for unauthenticated attackers to update checkout fields via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Checkout Field Editor

Software Type Plugin
Software Slug woocommerce-checkout-field-editor
Patched? Yes
Remediation Update to version 1.7.5, or a newer patched version
Affected Version
  • <= 1.7.4
Patched Version
  • 1.7.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.