Booster for WooCommerce <= 7.1.0 - Authenticated (Subscriber+) Information Disclosure via Shortcode

Information Exposure
CVE CVE-2023-4796
CVSS 4.3 (Medium)
Publicly Published September 13, 2023
Last Updated October 20, 2023
Researcher István Márton - Wordfence


The Booster for WooCommerce for WordPress is vulnerable to Information Disclosure via the 'wcj_wp_option' shortcode in versions up to, and including, 7.1.0 due to insufficient controls on the information retrievable via the shortcode. This makes it possible for authenticated attackers, with subscriber-level capabilities or above, to retrieve arbitrary sensitive site options.



1 affected software package

Software Type Plugin
Software Slug woocommerce-jetpack (view on
Patched? Yes
Remediation Update to version 7.1.1, or a newer patched version
Affected Version
  • <= 7.1.0
Patched Version
  • 7.1.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.