Booster for WooCommerce <= 7.1.8 - Unauthenticated Arbitrary Shortcode Execution

Improper Control of Generation of Code ('Code Injection')
CVE CVE-2024-3957
CVSS 6.5 (Medium)
Publicly Published May 1, 2024
Last Updated May 2, 2024
Researcher stealthcopter


The Booster for WooCommerce plugin is vulnerable to Unauthenticated Arbitrary Shortcode Execution in versions up to, and including, 7.1.8. This allows unauthenticated attackers to execute arbitrary shortcodes. The severity and exploitability depends on what other plugins are installed and what shortcode functionality they provide.



Vulnerability Details for Booster for WooCommerce

Software Type Plugin
Software Slug woocommerce-jetpack (view on
Patched? Yes
Remediation Update to version 7.1.9, or a newer patched version
Affected Version
  • <= 7.1.8
Patched Version
  • 7.1.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.