Mercado Pago payments for WooCommerce <= 6.3.1 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2022-45068
CVSS 4.3 (Medium)
Publicly Published February 6, 2023
Last Updated February 10, 2023
Researcher Muhammad Daffa


The Mercado Pago payments for WooCommerce plugin is vulnerable to Cross-Site Request Forgery in versions up to, and including, 6.6.0. This is due to missing or incorrect nonce validation on the multiple functions. This makes it possible for unauthenticated attackers to trick other users or visitors into creating or processing payments via a forged request.



1 affected software package

Software Type Plugin
Software Slug woocommerce-mercadopago (view on
Patched? Yes
Remediation Update to version 6.4.0, or a newer patched version
Affected Version
  • <= 6.3.1
Patched Version
  • 6.4.0

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.