WooCommerce Multi Currency <= 2.1.17 - Missing Authorization

Missing Authorization
CVE CVE-2021-4379
CVSS 6.5 (Medium)
Publicly Published September 13, 2021
Last Updated January 22, 2024
Researcher Jerome Bruandet - NinTechNet


The WooCommerce Multi Currency plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the wmc_bulk_fixed_price function in versions up to, and including, 2.1.17. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to make changes to product prices.



Vulnerability Details for WooCommerce Multi Currency

Software Type Plugin
Software Slug woocommerce-multi-currency
Patched? Yes
Remediation Update to version 2.1.18, or a newer patched version
Affected Version
  • <= 2.1.17
Patched Version
  • 2.1.18

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.