WooCommerce Multilingual & Multicurrency <= 5.3.4 - Missing Authorization

Missing Authorization
CVE CVE-2024-30466
CVSS 4.3 (Medium)
Publicly Published March 28, 2024
Last Updated April 3, 2024
Researcher Rafie Muhammad - Patchstack


The WooCommerce Multilingual & Multicurrency plugin for WordPress is vulnerable to unauthorized access due to a missing capability check in versions up to, and including, 5.3.4. This makes it possible for authenticated attackers, with subscriber-level access and above, to perform an unauthorized action.



Vulnerability Details for WooCommerce Multilingual & Multicurrency with WPML

Software Type Plugin
Software Slug woocommerce-multilingual (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.3.5, or a newer patched version
Affected Version
  • <= 5.3.4
Patched Version
  • 5.3.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.