WooCommerce POS <= 1.4.11 - Insufficient Verification of Data Authenticity to Authenticated (Customer+) Information Disclosure

4.3
Insufficient Verification of Data Authenticity
CVE CVE-2024-2384
CVSS 4.3 (Medium)
Publicly Published March 19, 2024
Last Updated March 20, 2024
Researcher Lucio Sá

Description

The WooCommerce POS plugin for WordPress is vulnerable to information disclosure in all versions up to, and including, 1.4.11. This is due to the plugin not properly verifying the authentication and authorization of the current user This makes it possible for authenticated attackers, with customer-level access and above, to view potentially sensitive information about other users by leveraging their order id

References

Share

Vulnerability Details for WooCommerce POS – Point of Sale (POS)

Software Type Plugin
Software Slug woocommerce-pos (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.4.12, or a newer patched version
Affected Version
  • <= 1.4.11
Patched Version
  • 1.4.12

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation