WooCommerce Pre-Orders <= 2.0.2 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-3508
CVSS 4.3 (Medium)
Publicly Published July 10, 2023
Last Updated July 14, 2023
Researcher Erwan LR - WPScan


The WooCommerce Pre-Orders plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.0.2. This is due to missing or incorrect nonce validation on several of its functions. This makes it possible for unauthenticated attackers to invoke these functions and perform actions such as email pre-order customers, change released dates, mark all pre-orders complete for specific products, and cancel pre-orders for products via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug woocommerce-pre-orders
Patched? Yes
Remediation Update to version 2.0.3, or a newer patched version
Affected Version
  • <= 2.0.2
Patched Version
  • 2.0.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.