Predictive Search for WooCommerce <= 1.0.5 - Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVSS 6.1 (Medium)
Publicly Published November 27, 2012
Last Updated December 16, 2022
Researcher Jason Flemming


The Predictive Search for WooCommerce plugin for WordPress is vulnerable to Cross-Site Scripting via the predictive search box in versions up to, and including, 1.0.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute in a victim's browser.



1 affected software package

Software Type Plugin
Software Slug woocommerce-predictive-search (view on
Patched? Yes
Remediation Update to version 1.0.6, or a newer patched version
Affected Version
  • <= 1.0.5
Patched Version
  • 1.0.6

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.