WooCommerce Predictive Search <= 5.8.0 - Cross-Site Request Forgery via multiple AJAX actions

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-32963
CVSS 5.3 (Medium)
Publicly Published May 18, 2023
Last Updated January 22, 2024
Researcher Mika


The WooCommerce Predictive Search plugin for WordPress is vulnerable to unauthorized modification of data due to a missing nonce check on multiple ajax sync functions in versions up to, and including, 5.8.0. This makes it possible for unauthenticated attackers to sync various product search results such as categories and SKUs, granted they can trick another user into performing an action, such as clicking on a link.



Vulnerability Details for Predictive Search for WooCommerce

Software Type Plugin
Software Slug woocommerce-predictive-search (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.8.1, or a newer patched version
Affected Version
  • <= 5.8.0
Patched Version
  • 5.8.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.