WooCommerce Predictive Search <= 5.8.0 - Missing Authorization via multiple AJAX actions

Missing Authorization
CVE CVE-2023-32963
CVSS 5.3 (Medium)
Publicly Published May 18, 2023
Last Updated May 22, 2023
Researcher Mika


The WooCommerce Predictive Search plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on multiple ajax sync functions in versions up to, and including, 5.8.0. This makes it possible for unauthenticated attackers to sync various product search results such as categories and SKUs.



1 affected software package

Software Type Plugin
Software Slug woocommerce-predictive-search (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.8.1, or a newer patched version
Affected Version
  • <= 5.8.0
Patched Version
  • 5.8.1

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.