PPOM for WooCommerce <= 18.3 - Authenticated Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2019-14948
CVSS 5.4 (Medium)
Publicly Published August 10, 2019
Last Updated November 24, 2022


The woocommerce-product-addon plugin before 18.4 for WordPress has XSS via an import of a new meta data structure.



Vulnerability Details for Product Addons & Fields for WooCommerce

Software Type Plugin
Software Slug woocommerce-product-addon (view on wordpress.org)
Patched? Yes
Remediation Update to version 18.4, or a newer patched version
Affected Version
  • < 18.4
Patched Version
  • 18.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.