PPOM for WooCommerce <= 23.9 - Missing Authorization to Stored Cross-Site Scripting

Missing Authorization
CVE CVE-2021-25018
CVSS 5.4 (Medium)
Publicly Published January 17, 2022
Last Updated January 22, 2024
Researcher Krzysztof Zając - CERT PL


The PPOM for WooCommerce WordPress plugin before 24.0 does not have authorisation and CSRF checks in the ppom_settings_panel_action AJAX action, allowing any authenticated to call it and set arbitrary settings. Furthermore, due to the lack of sanitisation and escaping, it could lead to Stored XSS issues



Vulnerability Details for Product Addons & Fields for WooCommerce

Software Type Plugin
Software Slug woocommerce-product-addon (view on wordpress.org)
Patched? Yes
Remediation Update to version 24.0, or a newer patched version
Affected Version
  • <= 23.9
Patched Version
  • 24.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.