WooCommerce Product Add-ons <= 6.1.3 - Authenticated (Shop Manager+) PHP Object Injection

Deserialization of Untrusted Data
CVE CVE-2023-32795
CVSS 7.2 (High)
Publicly Published May 15, 2023
Last Updated January 22, 2024
Researcher Rafie Muhammad - Patchstack


The WooCommerce Product Add-ons plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 6.1.3 via deserialization of untrusted input. This allows authenticated attackers, with shop manager permissions and above, to inject a PHP Object. It is unknown if a POP chain is also present in the plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.



Vulnerability Details for WooCommerce Product Add-ons

Software Type Plugin
Software Slug woocommerce-product-addons
Patched? Yes
Remediation Update to version 6.2.0, or a newer patched version
Affected Version
  • <= 6.1.3
Patched Version
  • 6.2.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.