Payment gateway per Product for WooCommerce <= 3.2.7 - Reflected Cross-Site Scripting

6.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-44144
CVSS 6.1 (Medium)
Publicly Published September 20, 2023
Last Updated September 28, 2023
Researcher SeungYongLee

Description

The Payment gateway per Product for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'PHP_SELF' in versions up to, and including, 3.2.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

References

Share

1 affected software package

Software Type Plugin
Software Slug woocommerce-product-payments (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.2.8, or a newer patched version
Affected Version
  • < 3.2.8
Patched Version
  • 3.2.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation