WooCommerce Stock Manager < 1.0.9 - Authorization Bypass

8.8
Missing Authorization
CVSS 8.8 (High)
Publicly Published July 25, 2016
Last Updated January 22, 2024

Description

The WooCommerce Stock Manager plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the stock_manager_table_variation_td function in versions up to, and including, 1.0.8. This makes it possible for authenticated attackers to edit or delete products.

References

Share

1 affected software package

Software Type Plugin
Software Slug woocommerce-stock-manager (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.0.8, or a newer patched version
Affected Version
  • <= 1.0.7
Patched Version
  • 1.0.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation